$re = '/[0-9]{2}(\.|\s)?[0-9]{3}(\.|\s)?[0-9]{2}\n/m';
$str = '80020509
80.020-050
80-250.404
80.405.405
80405.405';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);