# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Usuário Off-Line no SIGAA (?P<Nome>\D*)\s\(|Matrícula:\s(?P<Matricula>\d*)|Usuário:\s(?P<Usuario>\S*)|(?P<Email>\S*@\S*)"
test_str = ("Usuário Off-Line no SIGAA ANA CAROLINA CORREIA TORRES (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840041\n"
"Usuário: icarolcorreia\n"
"E-mail: aninhacorreia09@gmail.com\n"
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA BEATRIZ LOBATO DA SILVA (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840014\n"
"Usuário: beatrizlobato11\n"
"E-mail: BIALOBATO11@GMAIL.COM\n"
"Turma: 01A Enviar Mensagem\n"
" Usuário Off-Line no SIGAA BEATRIZ LOBATO NOGUEIRA FARIAS (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840034\n"
"Usuário: beatriznogueira\n"
"E-mail: lobatobnf@gmail.com\n"
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA BRUNA LETICIA PORTILHO FURTADO (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840026\n"
"Usuário: leticiafurtado07\n"
"E-mail: lfurt7@gmail.com\n"
"Turma: 01A Enviar Mensagem\n"
" Usuário Off-Line no SIGAA CAIO AUGUSTO DE ALMEIDA CANELAS (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840008\n"
"Usuário: caio1999\n"
"E-mail: caio.augusto.almeida1999@gmail.com\n"
"Turma: 01A Enviar Mensagem Usuário On-Line no SIGAA DAVI JOSUE MARCON (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840011\n"
"Usuário: davijm_\n"
"E-mail: Davijosuemarcon@gmail.com\n"
"Turma: 01A Enviar Mensagem\n"
" Usuário Off-Line no SIGAA DEBORA PINHEIRO BAHIA (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840013\n"
"Usuário: dpbahia\n"
"E-mail: dedapbahia@gmail.com\n"
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA DIOVANNA MIRELLA DOS SANTOS DA SILVA (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840007\n"
"Usuário: diovannasantos\n"
"E-mail: diovanna8university@gmail.com\n"
"Turma: 01A Enviar Mensagem\n"
" Usuário Off-Line no SIGAA EBERSON DA SILVA DE MACEDO (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201704840014\n"
"Usuário: ebersonmacedo\n"
"E-mail: eberson.macedo13@gmail.com\n"
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA ELIZANGELA PASTANA DO NASCIMENTO (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201604840023\n"
"Usuário: elizangelapastana\n"
"E-mail: pastanaelizangela@gmail.com\n"
"Turma: 01A Enviar Mensagem\n"
" Usuário Off-Line no SIGAA EVELY JUCIMAR PINTO DE MELO (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840043\n"
"Usuário: evely_melo\n"
"E-mail: evely.melojuc15@gmail.com\n"
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA EVESON OSCAR ALMEIDA CONCEICAO (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840033\n"
"Usuário: evesonos1\n"
"E-mail: evesonalmeida@hotmail.com\n"
"Turma: 01A Enviar Mensagem\n"
" Usuário Off-Line no SIGAA GABRIELA DOMINGAS GARCIA CAMPESTRINI (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840001\n"
"Usuário: campestrini\n"
"E-mail: gabrielad.campestrini@gmail.com\n"
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA GABRIELA VIEIRA PANTOJA (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840032\n"
"Usuário: gabrielapantoja\n"
"E-mail: gabivieirapantoja@hotmail.com\n"
"Turma: 01A Enviar Mensagem\n"
" Usuário Off-Line no SIGAA GIOVANE PINHEIRO CUNHA (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840018\n"
"Usuário: giovanep\n"
"E-mail: giovanep76@gmail.com\n"
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA GIOVANNA BEATRIZ PEREIRA PANTOJA (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840009\n"
"Usuário: 03265594262\n"
"E-mail: giovannabeatrizpantoja@hotmail.com\n"
"Turma: 01A Enviar Mensagem\n"
" Usuário Off-Line no SIGAA GLAUCIANE GONCALVES FERREIRA (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201604840037\n"
"Usuário: glaucianeferreira\n"
"E-mail: glaucianegferreira@gmail.com\n"
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA GREENBERG RAMOS VIANA (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840015\n"
"Usuário: greenberg\n"
"E-mail: greenbergrv@gmail.com\n"
"Turma: 01A Enviar Mensagem\n"
" Usuário Off-Line no SIGAA GUSTAVO MARQUES SERRA (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840002\n"
"Usuário: gustmar\n"
"E-mail: gustmarq4@gmail.com\n"
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA HEMELI BRITO PANTOJA (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840044\n"
"Usuário: hemeli\n"
"E-mail: thc2019@outlook.com.br\n"
"Turma: 01A Enviar Mensagem\n"
" Usuário Off-Line no SIGAA JOAO PEDRO ABRAHIM CHAVES (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840040\n"
"Usuário: jabrahim\n"
"E-mail: jpedroachaves@gmail.com\n"
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA JOAQUIM DA SILVA PINTO NETO (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840031\n"
"Usuário: joaquimpneto\n"
"E-mail: JOAQUIMNETO318@GMAIL.COM\n"
"Turma: 01A Enviar Mensagem\n"
" Usuário Off-Line no SIGAA KARINA KESIA DA SILVA AMARAL (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840021\n"
"Usuário: kahama\n"
"E-mail: karinaksamaral@gmail.com\n"
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA LARISSA YRIS PANTOJA DO NASCIMENTO (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201704840042\n"
"Usuário: larissayris\n"
"E-mail: lariissayris@gmail.com\n"
"Turma: 01A Enviar Mensagem\n"
" Usuário Off-Line no SIGAA LEONARDO LEONI MARTINS PINTO (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840003\n"
"Usuário: leoni99\n"
"E-mail: leonardoleoni99@gmail.com\n"
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA LOHAN PHELIPE VILHENA PANTOJA (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201704840003\n"
"Usuário: lohan\n"
"E-mail: lohan.p.v.pantoja@gmail.com\n"
"Turma: 01A Enviar Mensagem\n"
" Usuário Off-Line no SIGAA MAITE THAIS BARROS CAMPOS (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201604840029\n"
"Usuário: maitebiotec2016\n"
"E-mail: mtbcampos16@gmail.com\n"
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA MARIA VITORIA NAVA MOURA (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201604840011\n"
"Usuário: mnavamoura\n"
"E-mail: mnavamoura@gmail.com\n"
"Turma: 01A Enviar Mensagem\n"
" Usuário Off-Line no SIGAA MATHEUS HADIGO PIRES COSTA (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201704840015\n"
"Usuário: matheushadigo\n"
"E-mail: biohadgo@gmail.com\n"
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA NAIANA CORREA RIBEIRO (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840017\n"
"Usuário: naianaribeiro\n"
"E-mail: rnaiana34@gmail.com\n"
"Turma: 01A Enviar Mensagem\n"
" Usuário Off-Line no SIGAA PATRICK DAWIS PEIXOTO SANTOS (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201604840016\n"
"Usuário: patrickdawis\n"
"E-mail: patrickdawi@hotmail.com\n"
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA PATRICK VIERA GOMES ARAUJO (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840030\n"
"Usuário: patrick8956\n"
"E-mail: ztpatrick19@gmail.com\n"
"Turma: 01A Enviar Mensagem\n"
" Usuário Off-Line no SIGAA PAULA MARQUES SERRA TEIXEIRA (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201704840004\n"
"Usuário: paulanmarques\n"
"E-mail: paulanmarques@gmail.com\n"
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA PIERRE FLEMMING MOTA COSTA DOS REIS FILHO (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840035\n"
"Usuário: pierre22\n"
"E-mail: pierrereis22@gmail.com\n"
"Turma: 01A Enviar Mensagem\n"
" Usuário Off-Line no SIGAA THAIS FERREIRA BRAGA (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840025\n"
"Usuário: thaisferreira094\n"
"E-mail: thaisferreira094@gmail.com\n"
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA THAIS MAYARA CASTRO DOS ANJOS (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840004\n"
"Usuário: mayanjos\n"
"E-mail: mayacastro326@gmail.com\n"
"Turma: 01A Enviar Mensagem\n"
" Usuário Off-Line no SIGAA THAIZE CAROLINY ANETE DO ROSARIO (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840005\n"
"Usuário: thaizear\n"
"E-mail: thaize.ar@gmail.com\n"
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA THAYSA DE SOUSA REIS (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840006\n"
"Usuário: thayreis\n"
"E-mail: thaysareis9@gmail.com\n"
"Turma: 01A Enviar Mensagem\n"
" Usuário Off-Line no SIGAA THIAGO BORGES CORDEIRO (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840027\n"
"Usuário: thgbc\n"
"E-mail: thiagoborgescordeiro@live.com\n"
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA VALERIA CRISTIANE SANTOS DA SILVA (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840024\n"
"Usuário: vc0024\n"
"E-mail: vcssilva505@gmail.com\n"
"Turma: 01A Enviar Mensagem\n"
" Usuário Off-Line no SIGAA WICTORIA FARIAS DIAS (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840029\n"
"Usuário: wictoria222\n"
"E-mail: wictoriafariasdias@gmail.com\n"
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA YAN CARVALHO MAGNO (Perfil)\n"
"Curso: BIOTECNOLOGIA/ICB\n"
"Matrícula: 201804840036\n"
"Usuário: yanmagno\n"
"E-mail: yan.magno47@gmail.com\n"
"Turma: 01A")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.