$re = '/Usuário Off-Line no SIGAA (?P<Nome>\D*)\s\(|Matrícula:\s(?P<Matricula>\d*)|Usuário:\s(?P<Usuario>\S*)|(?P<Email>\S*@\S*)/m';
$str = 'Usuário Off-Line no SIGAA ANA CAROLINA CORREIA TORRES (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840041
Usuário: icarolcorreia
E-mail: aninhacorreia09@gmail.com
Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA BEATRIZ LOBATO DA SILVA (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840014
Usuário: beatrizlobato11
E-mail: BIALOBATO11@GMAIL.COM
Turma: 01A Enviar Mensagem
Usuário Off-Line no SIGAA BEATRIZ LOBATO NOGUEIRA FARIAS (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840034
Usuário: beatriznogueira
E-mail: lobatobnf@gmail.com
Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA BRUNA LETICIA PORTILHO FURTADO (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840026
Usuário: leticiafurtado07
E-mail: lfurt7@gmail.com
Turma: 01A Enviar Mensagem
Usuário Off-Line no SIGAA CAIO AUGUSTO DE ALMEIDA CANELAS (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840008
Usuário: caio1999
E-mail: caio.augusto.almeida1999@gmail.com
Turma: 01A Enviar Mensagem Usuário On-Line no SIGAA DAVI JOSUE MARCON (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840011
Usuário: davijm_
E-mail: Davijosuemarcon@gmail.com
Turma: 01A Enviar Mensagem
Usuário Off-Line no SIGAA DEBORA PINHEIRO BAHIA (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840013
Usuário: dpbahia
E-mail: dedapbahia@gmail.com
Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA DIOVANNA MIRELLA DOS SANTOS DA SILVA (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840007
Usuário: diovannasantos
E-mail: diovanna8university@gmail.com
Turma: 01A Enviar Mensagem
Usuário Off-Line no SIGAA EBERSON DA SILVA DE MACEDO (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201704840014
Usuário: ebersonmacedo
E-mail: eberson.macedo13@gmail.com
Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA ELIZANGELA PASTANA DO NASCIMENTO (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201604840023
Usuário: elizangelapastana
E-mail: pastanaelizangela@gmail.com
Turma: 01A Enviar Mensagem
Usuário Off-Line no SIGAA EVELY JUCIMAR PINTO DE MELO (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840043
Usuário: evely_melo
E-mail: evely.melojuc15@gmail.com
Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA EVESON OSCAR ALMEIDA CONCEICAO (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840033
Usuário: evesonos1
E-mail: evesonalmeida@hotmail.com
Turma: 01A Enviar Mensagem
Usuário Off-Line no SIGAA GABRIELA DOMINGAS GARCIA CAMPESTRINI (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840001
Usuário: campestrini
E-mail: gabrielad.campestrini@gmail.com
Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA GABRIELA VIEIRA PANTOJA (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840032
Usuário: gabrielapantoja
E-mail: gabivieirapantoja@hotmail.com
Turma: 01A Enviar Mensagem
Usuário Off-Line no SIGAA GIOVANE PINHEIRO CUNHA (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840018
Usuário: giovanep
E-mail: giovanep76@gmail.com
Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA GIOVANNA BEATRIZ PEREIRA PANTOJA (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840009
Usuário: 03265594262
E-mail: giovannabeatrizpantoja@hotmail.com
Turma: 01A Enviar Mensagem
Usuário Off-Line no SIGAA GLAUCIANE GONCALVES FERREIRA (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201604840037
Usuário: glaucianeferreira
E-mail: glaucianegferreira@gmail.com
Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA GREENBERG RAMOS VIANA (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840015
Usuário: greenberg
E-mail: greenbergrv@gmail.com
Turma: 01A Enviar Mensagem
Usuário Off-Line no SIGAA GUSTAVO MARQUES SERRA (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840002
Usuário: gustmar
E-mail: gustmarq4@gmail.com
Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA HEMELI BRITO PANTOJA (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840044
Usuário: hemeli
E-mail: thc2019@outlook.com.br
Turma: 01A Enviar Mensagem
Usuário Off-Line no SIGAA JOAO PEDRO ABRAHIM CHAVES (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840040
Usuário: jabrahim
E-mail: jpedroachaves@gmail.com
Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA JOAQUIM DA SILVA PINTO NETO (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840031
Usuário: joaquimpneto
E-mail: JOAQUIMNETO318@GMAIL.COM
Turma: 01A Enviar Mensagem
Usuário Off-Line no SIGAA KARINA KESIA DA SILVA AMARAL (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840021
Usuário: kahama
E-mail: karinaksamaral@gmail.com
Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA LARISSA YRIS PANTOJA DO NASCIMENTO (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201704840042
Usuário: larissayris
E-mail: lariissayris@gmail.com
Turma: 01A Enviar Mensagem
Usuário Off-Line no SIGAA LEONARDO LEONI MARTINS PINTO (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840003
Usuário: leoni99
E-mail: leonardoleoni99@gmail.com
Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA LOHAN PHELIPE VILHENA PANTOJA (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201704840003
Usuário: lohan
E-mail: lohan.p.v.pantoja@gmail.com
Turma: 01A Enviar Mensagem
Usuário Off-Line no SIGAA MAITE THAIS BARROS CAMPOS (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201604840029
Usuário: maitebiotec2016
E-mail: mtbcampos16@gmail.com
Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA MARIA VITORIA NAVA MOURA (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201604840011
Usuário: mnavamoura
E-mail: mnavamoura@gmail.com
Turma: 01A Enviar Mensagem
Usuário Off-Line no SIGAA MATHEUS HADIGO PIRES COSTA (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201704840015
Usuário: matheushadigo
E-mail: biohadgo@gmail.com
Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA NAIANA CORREA RIBEIRO (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840017
Usuário: naianaribeiro
E-mail: rnaiana34@gmail.com
Turma: 01A Enviar Mensagem
Usuário Off-Line no SIGAA PATRICK DAWIS PEIXOTO SANTOS (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201604840016
Usuário: patrickdawis
E-mail: patrickdawi@hotmail.com
Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA PATRICK VIERA GOMES ARAUJO (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840030
Usuário: patrick8956
E-mail: ztpatrick19@gmail.com
Turma: 01A Enviar Mensagem
Usuário Off-Line no SIGAA PAULA MARQUES SERRA TEIXEIRA (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201704840004
Usuário: paulanmarques
E-mail: paulanmarques@gmail.com
Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA PIERRE FLEMMING MOTA COSTA DOS REIS FILHO (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840035
Usuário: pierre22
E-mail: pierrereis22@gmail.com
Turma: 01A Enviar Mensagem
Usuário Off-Line no SIGAA THAIS FERREIRA BRAGA (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840025
Usuário: thaisferreira094
E-mail: thaisferreira094@gmail.com
Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA THAIS MAYARA CASTRO DOS ANJOS (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840004
Usuário: mayanjos
E-mail: mayacastro326@gmail.com
Turma: 01A Enviar Mensagem
Usuário Off-Line no SIGAA THAIZE CAROLINY ANETE DO ROSARIO (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840005
Usuário: thaizear
E-mail: thaize.ar@gmail.com
Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA THAYSA DE SOUSA REIS (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840006
Usuário: thayreis
E-mail: thaysareis9@gmail.com
Turma: 01A Enviar Mensagem
Usuário Off-Line no SIGAA THIAGO BORGES CORDEIRO (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840027
Usuário: thgbc
E-mail: thiagoborgescordeiro@live.com
Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA VALERIA CRISTIANE SANTOS DA SILVA (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840024
Usuário: vc0024
E-mail: vcssilva505@gmail.com
Turma: 01A Enviar Mensagem
Usuário Off-Line no SIGAA WICTORIA FARIAS DIAS (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840029
Usuário: wictoria222
E-mail: wictoriafariasdias@gmail.com
Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA YAN CARVALHO MAGNO (Perfil)
Curso: BIOTECNOLOGIA/ICB
Matrícula: 201804840036
Usuário: yanmagno
E-mail: yan.magno47@gmail.com
Turma: 01A';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);