#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Usuário Off-Line no SIGAA (?P<Nome>\D*)\s\(|Matrícula:\s(?P<Matricula>\d*)|Usuário:\s(?P<Usuario>\S*)|(?P<Email>\S*@\S*)"
Local $sString = "Usuário Off-Line no SIGAA ANA CAROLINA CORREIA TORRES (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840041" & @CRLF & _
"Usuário: icarolcorreia" & @CRLF & _
"E-mail: aninhacorreia09@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA BEATRIZ LOBATO DA SILVA (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840014" & @CRLF & _
"Usuário: beatrizlobato11" & @CRLF & _
"E-mail: BIALOBATO11@GMAIL.COM" & @CRLF & _
"Turma: 01A Enviar Mensagem" & @CRLF & _
" Usuário Off-Line no SIGAA BEATRIZ LOBATO NOGUEIRA FARIAS (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840034" & @CRLF & _
"Usuário: beatriznogueira" & @CRLF & _
"E-mail: lobatobnf@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA BRUNA LETICIA PORTILHO FURTADO (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840026" & @CRLF & _
"Usuário: leticiafurtado07" & @CRLF & _
"E-mail: lfurt7@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem" & @CRLF & _
" Usuário Off-Line no SIGAA CAIO AUGUSTO DE ALMEIDA CANELAS (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840008" & @CRLF & _
"Usuário: caio1999" & @CRLF & _
"E-mail: caio.augusto.almeida1999@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem Usuário On-Line no SIGAA DAVI JOSUE MARCON (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840011" & @CRLF & _
"Usuário: davijm_" & @CRLF & _
"E-mail: Davijosuemarcon@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem" & @CRLF & _
" Usuário Off-Line no SIGAA DEBORA PINHEIRO BAHIA (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840013" & @CRLF & _
"Usuário: dpbahia" & @CRLF & _
"E-mail: dedapbahia@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA DIOVANNA MIRELLA DOS SANTOS DA SILVA (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840007" & @CRLF & _
"Usuário: diovannasantos" & @CRLF & _
"E-mail: diovanna8university@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem" & @CRLF & _
" Usuário Off-Line no SIGAA EBERSON DA SILVA DE MACEDO (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201704840014" & @CRLF & _
"Usuário: ebersonmacedo" & @CRLF & _
"E-mail: eberson.macedo13@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA ELIZANGELA PASTANA DO NASCIMENTO (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201604840023" & @CRLF & _
"Usuário: elizangelapastana" & @CRLF & _
"E-mail: pastanaelizangela@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem" & @CRLF & _
" Usuário Off-Line no SIGAA EVELY JUCIMAR PINTO DE MELO (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840043" & @CRLF & _
"Usuário: evely_melo" & @CRLF & _
"E-mail: evely.melojuc15@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA EVESON OSCAR ALMEIDA CONCEICAO (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840033" & @CRLF & _
"Usuário: evesonos1" & @CRLF & _
"E-mail: evesonalmeida@hotmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem" & @CRLF & _
" Usuário Off-Line no SIGAA GABRIELA DOMINGAS GARCIA CAMPESTRINI (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840001" & @CRLF & _
"Usuário: campestrini" & @CRLF & _
"E-mail: gabrielad.campestrini@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA GABRIELA VIEIRA PANTOJA (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840032" & @CRLF & _
"Usuário: gabrielapantoja" & @CRLF & _
"E-mail: gabivieirapantoja@hotmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem" & @CRLF & _
" Usuário Off-Line no SIGAA GIOVANE PINHEIRO CUNHA (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840018" & @CRLF & _
"Usuário: giovanep" & @CRLF & _
"E-mail: giovanep76@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA GIOVANNA BEATRIZ PEREIRA PANTOJA (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840009" & @CRLF & _
"Usuário: 03265594262" & @CRLF & _
"E-mail: giovannabeatrizpantoja@hotmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem" & @CRLF & _
" Usuário Off-Line no SIGAA GLAUCIANE GONCALVES FERREIRA (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201604840037" & @CRLF & _
"Usuário: glaucianeferreira" & @CRLF & _
"E-mail: glaucianegferreira@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA GREENBERG RAMOS VIANA (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840015" & @CRLF & _
"Usuário: greenberg" & @CRLF & _
"E-mail: greenbergrv@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem" & @CRLF & _
" Usuário Off-Line no SIGAA GUSTAVO MARQUES SERRA (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840002" & @CRLF & _
"Usuário: gustmar" & @CRLF & _
"E-mail: gustmarq4@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA HEMELI BRITO PANTOJA (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840044" & @CRLF & _
"Usuário: hemeli" & @CRLF & _
"E-mail: thc2019@outlook.com.br" & @CRLF & _
"Turma: 01A Enviar Mensagem" & @CRLF & _
" Usuário Off-Line no SIGAA JOAO PEDRO ABRAHIM CHAVES (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840040" & @CRLF & _
"Usuário: jabrahim" & @CRLF & _
"E-mail: jpedroachaves@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA JOAQUIM DA SILVA PINTO NETO (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840031" & @CRLF & _
"Usuário: joaquimpneto" & @CRLF & _
"E-mail: JOAQUIMNETO318@GMAIL.COM" & @CRLF & _
"Turma: 01A Enviar Mensagem" & @CRLF & _
" Usuário Off-Line no SIGAA KARINA KESIA DA SILVA AMARAL (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840021" & @CRLF & _
"Usuário: kahama" & @CRLF & _
"E-mail: karinaksamaral@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA LARISSA YRIS PANTOJA DO NASCIMENTO (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201704840042" & @CRLF & _
"Usuário: larissayris" & @CRLF & _
"E-mail: lariissayris@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem" & @CRLF & _
" Usuário Off-Line no SIGAA LEONARDO LEONI MARTINS PINTO (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840003" & @CRLF & _
"Usuário: leoni99" & @CRLF & _
"E-mail: leonardoleoni99@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA LOHAN PHELIPE VILHENA PANTOJA (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201704840003" & @CRLF & _
"Usuário: lohan" & @CRLF & _
"E-mail: lohan.p.v.pantoja@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem" & @CRLF & _
" Usuário Off-Line no SIGAA MAITE THAIS BARROS CAMPOS (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201604840029" & @CRLF & _
"Usuário: maitebiotec2016" & @CRLF & _
"E-mail: mtbcampos16@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA MARIA VITORIA NAVA MOURA (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201604840011" & @CRLF & _
"Usuário: mnavamoura" & @CRLF & _
"E-mail: mnavamoura@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem" & @CRLF & _
" Usuário Off-Line no SIGAA MATHEUS HADIGO PIRES COSTA (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201704840015" & @CRLF & _
"Usuário: matheushadigo" & @CRLF & _
"E-mail: biohadgo@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA NAIANA CORREA RIBEIRO (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840017" & @CRLF & _
"Usuário: naianaribeiro" & @CRLF & _
"E-mail: rnaiana34@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem" & @CRLF & _
" Usuário Off-Line no SIGAA PATRICK DAWIS PEIXOTO SANTOS (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201604840016" & @CRLF & _
"Usuário: patrickdawis" & @CRLF & _
"E-mail: patrickdawi@hotmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA PATRICK VIERA GOMES ARAUJO (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840030" & @CRLF & _
"Usuário: patrick8956" & @CRLF & _
"E-mail: ztpatrick19@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem" & @CRLF & _
" Usuário Off-Line no SIGAA PAULA MARQUES SERRA TEIXEIRA (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201704840004" & @CRLF & _
"Usuário: paulanmarques" & @CRLF & _
"E-mail: paulanmarques@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA PIERRE FLEMMING MOTA COSTA DOS REIS FILHO (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840035" & @CRLF & _
"Usuário: pierre22" & @CRLF & _
"E-mail: pierrereis22@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem" & @CRLF & _
" Usuário Off-Line no SIGAA THAIS FERREIRA BRAGA (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840025" & @CRLF & _
"Usuário: thaisferreira094" & @CRLF & _
"E-mail: thaisferreira094@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA THAIS MAYARA CASTRO DOS ANJOS (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840004" & @CRLF & _
"Usuário: mayanjos" & @CRLF & _
"E-mail: mayacastro326@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem" & @CRLF & _
" Usuário Off-Line no SIGAA THAIZE CAROLINY ANETE DO ROSARIO (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840005" & @CRLF & _
"Usuário: thaizear" & @CRLF & _
"E-mail: thaize.ar@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA THAYSA DE SOUSA REIS (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840006" & @CRLF & _
"Usuário: thayreis" & @CRLF & _
"E-mail: thaysareis9@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem" & @CRLF & _
" Usuário Off-Line no SIGAA THIAGO BORGES CORDEIRO (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840027" & @CRLF & _
"Usuário: thgbc" & @CRLF & _
"E-mail: thiagoborgescordeiro@live.com" & @CRLF & _
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA VALERIA CRISTIANE SANTOS DA SILVA (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840024" & @CRLF & _
"Usuário: vc0024" & @CRLF & _
"E-mail: vcssilva505@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem" & @CRLF & _
" Usuário Off-Line no SIGAA WICTORIA FARIAS DIAS (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840029" & @CRLF & _
"Usuário: wictoria222" & @CRLF & _
"E-mail: wictoriafariasdias@gmail.com" & @CRLF & _
"Turma: 01A Enviar Mensagem Usuário Off-Line no SIGAA YAN CARVALHO MAGNO (Perfil)" & @CRLF & _
"Curso: BIOTECNOLOGIA/ICB" & @CRLF & _
"Matrícula: 201804840036" & @CRLF & _
"Usuário: yanmagno" & @CRLF & _
"E-mail: yan.magno47@gmail.com" & @CRLF & _
"Turma: 01A"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")