# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(34[0-9]{2}[ -])([0-9]{6}[ -])[0-9]{5}\b|\b34[0-9]{13}\b|\b(37[0-9]{2}[ -])([0-9]{6}[ -])[0-9]{5}\b|\b37[0-9]{13}\b"
test_str = ("American Express\n"
"Requirements: American Express cards start with the number 34 or 37 and have 15 digits. Pattern is 4-6-5 when having spaces or dashes.\n\n"
"Pattern Parts:\n"
"Starts with number 34 and 15 length:\n"
"1) \\b(34[0-9]{2}[ -])([0-9]{6}[ -])[0-9]{5}\\b|\\b34[0-9]{13}\\b \n\n"
"Starts with number 37 and 15 length:\n"
"2) \\b(37[0-9]{2}[ -])([0-9]{6}[ -])[0-9]{5}\\b|\\b37[0-9]{13}\\b\n\n\n"
"Combining 1-2 to form one pattern:\n"
"\\b(34[0-9]{2}[ -])([0-9]{6}[ -])[0-9]{5}\\b|\\b34[0-9]{13}\\b|\\b(37[0-9]{2}[ -])([0-9]{6}[ -])[0-9]{5}\\b|\\b37[0-9]{13}\\b\n\n\n"
"Test Cases:\n"
"Positive (Should fire):\n"
"15 length, no space, start with 34 342312341234112\n"
"15 length, dashes, start with 34 3423-123456-12345\n"
"15 length, spaces, start with 34 3423 123456 12345\n\n"
"15 length, no space, start with 37 372112341234123\n"
"15 length, dashes, start with 37 3721-123456-12345\n"
"15 length, spaces, start with 37 3721 123456 12345\n\n"
"Embedded in sentence with space:\n"
"15 length, no space, start with 34 Here is the cc: 342312341234112\n"
"15 length, dashes, start with 34 Here is the cc: 3423-123456-12345\n"
"15 length, spaces, start with 34 Here is the cc: 3423 123456 12345\n\n"
"15 length, no space, start with 37 Here is the cc: 372112341234123\n"
"15 length, dashes, start with 37 Here is the cc: 3721-123456-12345\n"
"15 length, spaces, start with 37 Here is the cc: 3721 123456 12345\n\n"
"15 length, no space, start with 34 Credit Card#:342312341234112\n"
"15 length, dashes, start with 34 Credit Card#:3423-123456-12345\n"
"15 length, spaces, start with 34 Credit Card#:3423 123456 12345\n\n"
"15 length, no space, start with 37 Credit Card#:372112341234123\n"
"15 length, dashes, start with 37 Credit Card#:3721-123456-12345\n"
"15 length, spaces, start with 37 Credit Card#:3721 123456 12345\n\n"
"Negative (Should Not Fire):\n"
"15 length, no space, not start with 34 352312341234112\n"
"15 length, dashes, not start with 34 3523-123456-12345\n"
"15 length, spaces, not start with 34 3523 123456 12345\n\n"
"15 length, no space, not start with 37 362112341234123\n"
"15 length, dashes, not start with 37 3621-123456-12345\n"
"15 length, spaces, not start with 37 3621 123456 12345\n\n"
"15 length, no space, start with 34, embedded Credit Card Number342312341234112\n"
"15 length, dashes, start with 34, malformed 3423-1234-1234-112\n\n"
"15 length num matching pattern but embedded User ID: 000000342312341234112000000")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.