#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(34[0-9]{2}[ -])([0-9]{6}[ -])[0-9]{5}\b|\b34[0-9]{13}\b|\b(37[0-9]{2}[ -])([0-9]{6}[ -])[0-9]{5}\b|\b37[0-9]{13}\b"
Local $sString = "American Express" & @CRLF & _
"Requirements: American Express cards start with the number 34 or 37 and have 15 digits. Pattern is 4-6-5 when having spaces or dashes." & @CRLF & _
"" & @CRLF & _
"Pattern Parts:" & @CRLF & _
"Starts with number 34 and 15 length:" & @CRLF & _
"1) \b(34[0-9]{2}[ -])([0-9]{6}[ -])[0-9]{5}\b|\b34[0-9]{13}\b " & @CRLF & _
"" & @CRLF & _
"Starts with number 37 and 15 length:" & @CRLF & _
"2) \b(37[0-9]{2}[ -])([0-9]{6}[ -])[0-9]{5}\b|\b37[0-9]{13}\b" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Combining 1-2 to form one pattern:" & @CRLF & _
"\b(34[0-9]{2}[ -])([0-9]{6}[ -])[0-9]{5}\b|\b34[0-9]{13}\b|\b(37[0-9]{2}[ -])([0-9]{6}[ -])[0-9]{5}\b|\b37[0-9]{13}\b" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Test Cases:" & @CRLF & _
"Positive (Should fire):" & @CRLF & _
"15 length, no space, start with 34 342312341234112" & @CRLF & _
"15 length, dashes, start with 34 3423-123456-12345" & @CRLF & _
"15 length, spaces, start with 34 3423 123456 12345" & @CRLF & _
"" & @CRLF & _
"15 length, no space, start with 37 372112341234123" & @CRLF & _
"15 length, dashes, start with 37 3721-123456-12345" & @CRLF & _
"15 length, spaces, start with 37 3721 123456 12345" & @CRLF & _
"" & @CRLF & _
"Embedded in sentence with space:" & @CRLF & _
"15 length, no space, start with 34 Here is the cc: 342312341234112" & @CRLF & _
"15 length, dashes, start with 34 Here is the cc: 3423-123456-12345" & @CRLF & _
"15 length, spaces, start with 34 Here is the cc: 3423 123456 12345" & @CRLF & _
"" & @CRLF & _
"15 length, no space, start with 37 Here is the cc: 372112341234123" & @CRLF & _
"15 length, dashes, start with 37 Here is the cc: 3721-123456-12345" & @CRLF & _
"15 length, spaces, start with 37 Here is the cc: 3721 123456 12345" & @CRLF & _
"" & @CRLF & _
"15 length, no space, start with 34 Credit Card#:342312341234112" & @CRLF & _
"15 length, dashes, start with 34 Credit Card#:3423-123456-12345" & @CRLF & _
"15 length, spaces, start with 34 Credit Card#:3423 123456 12345" & @CRLF & _
"" & @CRLF & _
"15 length, no space, start with 37 Credit Card#:372112341234123" & @CRLF & _
"15 length, dashes, start with 37 Credit Card#:3721-123456-12345" & @CRLF & _
"15 length, spaces, start with 37 Credit Card#:3721 123456 12345" & @CRLF & _
"" & @CRLF & _
"Negative (Should Not Fire):" & @CRLF & _
"15 length, no space, not start with 34 352312341234112" & @CRLF & _
"15 length, dashes, not start with 34 3523-123456-12345" & @CRLF & _
"15 length, spaces, not start with 34 3523 123456 12345" & @CRLF & _
"" & @CRLF & _
"15 length, no space, not start with 37 362112341234123" & @CRLF & _
"15 length, dashes, not start with 37 3621-123456-12345" & @CRLF & _
"15 length, spaces, not start with 37 3621 123456 12345" & @CRLF & _
"" & @CRLF & _
"15 length, no space, start with 34, embedded Credit Card Number342312341234112" & @CRLF & _
"15 length, dashes, start with 34, malformed 3423-1234-1234-112" & @CRLF & _
"" & @CRLF & _
"15 length num matching pattern but embedded User ID: 000000342312341234112000000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")