const regex = new RegExp('^(?:http|https):\\/\\/www.pitchup.com\\/(?P<lang>[^/]+/)?campsites/(?:(?!-/)[^/]+/){5}\\??.*$', 'gm')
const str = `https://www.pitchup.com/campsites/England/South_West/Cornwall/Helston/chy-carne-camping-and-touring-park/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}