import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:http|https):\\/\\/www.pitchup.com\\/(?P<lang>[^/]+/)?campsites/(?:(?!-/)[^/]+/){5}\\??.*$";
final String string = "https://www.pitchup.com/campsites/England/South_West/Cornwall/Helston/chy-carne-camping-and-touring-park/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}