#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:http|https):\/\/www.pitchup.com\/(?P<lang>[^/]+/)?campsites/(?:(?!-/)[^/]+/){5}\??.*$"
Local $sString = "https://www.pitchup.com/campsites/England/South_West/Cornwall/Helston/chy-carne-camping-and-touring-park/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")