$re = '//\*\n?\r?
(?: \* ©20\d{2}.*\n?\r?)
(?: \*(?:.*\n?\r?))+
\*//m';
$str = '/*
* ©2012 <!-- start slipsum code -->
*
* Do you see any Teletubbies in here? Do you see a slender plastic tag clipped to my shirt with my name printed on it? Do you see a little Asian child with a blank expression on his face
* sitting outside on a mechanical helicopter that shakes when you put quarters in it? No? Well, that\'s what you see at a toy store. And you must think you\'re in a toy store, because you\'re here shopping for an infant named Jeb.
* <!-- end slipsum code -->
*/
/*
* ©2021 <!-- start slipsum code -->
*
* Do you see any Teletubbies in here? Do you see a slender plastic tag clipped to my shirt with my name printed on it? Do you see a little Asian child with a blank expression on his face
* sitting outside on a mechanical helicopter that shakes when you put quarters in it? No? Well, that\'s what you see at a toy store. And you must think you\'re in a toy store, because you\'re here shopping for an infant named Jeb.
* <!-- end slipsum code -->
*/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);