using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/\*\n?\r?
(?: \* ©20\d{2}.*\n?\r?)
(?: \*(?:.*\n?\r?))+
\*/";
string input = @"/*
* ©2012 <!-- start slipsum code -->
*
* Do you see any Teletubbies in here? Do you see a slender plastic tag clipped to my shirt with my name printed on it? Do you see a little Asian child with a blank expression on his face
* sitting outside on a mechanical helicopter that shakes when you put quarters in it? No? Well, that's what you see at a toy store. And you must think you're in a toy store, because you're here shopping for an infant named Jeb.
* <!-- end slipsum code -->
*/
/*
* ©2021 <!-- start slipsum code -->
*
* Do you see any Teletubbies in here? Do you see a slender plastic tag clipped to my shirt with my name printed on it? Do you see a little Asian child with a blank expression on his face
* sitting outside on a mechanical helicopter that shakes when you put quarters in it? No? Well, that's what you see at a toy store. And you must think you're in a toy store, because you're here shopping for an infant named Jeb.
* <!-- end slipsum code -->
*/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}