import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/\\*\\n?\\r?\n"
+ "(?: \\* ©20\\d{2}.*\\n?\\r?)\n"
+ "(?: \\*(?:.*\\n?\\r?))+\n"
+ " \\*/";
final String string = "/*\n"
+ " * ©2012 <!-- start slipsum code -->\n"
+ " *\n"
+ " * Do you see any Teletubbies in here? Do you see a slender plastic tag clipped to my shirt with my name printed on it? Do you see a little Asian child with a blank expression on his face\n"
+ " * sitting outside on a mechanical helicopter that shakes when you put quarters in it? No? Well, that's what you see at a toy store. And you must think you're in a toy store, because you're here shopping for an infant named Jeb.\n"
+ " * <!-- end slipsum code -->\n"
+ " */\n\n"
+ "/*\n"
+ " * ©2021 <!-- start slipsum code -->\n"
+ " *\n"
+ " * Do you see any Teletubbies in here? Do you see a slender plastic tag clipped to my shirt with my name printed on it? Do you see a little Asian child with a blank expression on his face\n"
+ " * sitting outside on a mechanical helicopter that shakes when you put quarters in it? No? Well, that's what you see at a toy store. And you must think you're in a toy store, because you're here shopping for an infant named Jeb.\n"
+ " * <!-- end slipsum code -->\n"
+ " */";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}