$re = '/^[0-9]+$/si';
$str = '.144.44.';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;