use strict;
my $str = '.144.44.';
my $regex = qr/^[0-9]+$/sip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";