const regex = /^[0-9]+$/si;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9]+$', 'si')
const str = `.144.44.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);