re = /\B#([a-fA-F0-9]{6}|[a-fA-F0-9]{3})\b/
str = '#fff
#fefefe
#242424
#24ff33
#24ff3o // o is not a valid hex value
#ffg // g is not a valid hex value'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end