import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\B#([a-fA-F0-9]{6}|[a-fA-F0-9]{3})\\b";
final String string = "#fff\n"
+ "#fefefe\n"
+ "#242424\n"
+ "#24ff33\n"
+ "#24ff3o // o is not a valid hex value\n"
+ "#ffg // g is not a valid hex value";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}