using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\B#([a-fA-F0-9]{6}|[a-fA-F0-9]{3})\b";
string input = @"#fff
#fefefe
#242424
#24ff33
#24ff3o // o is not a valid hex value
#ffg // g is not a valid hex value";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}