re = /^(.)\1*([\w\W]+?)(.)\3*(?!\3)$/mi
str = '////strip me$$" becomes "/strip me$"
"/strip me$""/strip me$""/strip me$"
"/strip me$"
"/strip me$""""'
subst = '$1$2$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result