# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.)\1*([\w\W]+?)(.)\3*(?!\3)$/$1$2$3/gmi;t' <<< "////strip me$$\" becomes \"/strip me$\"
\"/strip me$\"\"/strip me$\"\"/strip me$\"
\"/strip me$\"
\"/strip me$\"\"\"\""