const regex = /^(.)\1*([\w\W]+?)(.)\3*(?!\3)$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.)\\1*([\\w\\W]+?)(.)\\3*(?!\\3)$', 'gmi')
const str = `////strip me\$\$" becomes "/strip me\$"
"/strip me\$""/strip me\$""/strip me\$"
"/strip me\$"
"/strip me\$""""`;
const subst = `$1$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);