# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[a]\w+"
test_str = ("\n"
"a dance high our spouse\n"
"able danger hill out spring\n"
"about dark him outside square\n"
"above daughter himself over stairs\n"
"accident day hint own stairway\n"
"acid decide his oxygen stand\n"
"across decided history page stars\n"
"act decimal hold paint start\n"
"add deep hole pair state\n"
"admission delivery home pants statement\n"
"Africa dentist hope paper stay\n"
"after deposit horse paragraph step\n"
"again describe hospital parents stick\n"
"against desert hot park still\n"
"age design hotel part stone\n"
"ago desk hours party stood\n"
"agree destination house passed stop\n"
"aide developed how passengers store\n"
"air diary however password storm\n"
"alarm dictionary huge past story\n"
"all did human pattern stove\n"
"almost didn't hundred pay straight\n"
"alone died husband payment strange\n"
"already difference I pedestrians street\n"
"also different I'll pen strong\n"
"although digital ice pencil students\n"
"always diner idea people study\n"
"am dinner if per subject\n"
"ambulance direct important period subtract\n"
"America direction in perishable subway\n"
"amount directions inches person such")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.