#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a]\w+"
Local $sString = "" & @CRLF & _
"a dance high our spouse" & @CRLF & _
"able danger hill out spring" & @CRLF & _
"about dark him outside square" & @CRLF & _
"above daughter himself over stairs" & @CRLF & _
"accident day hint own stairway" & @CRLF & _
"acid decide his oxygen stand" & @CRLF & _
"across decided history page stars" & @CRLF & _
"act decimal hold paint start" & @CRLF & _
"add deep hole pair state" & @CRLF & _
"admission delivery home pants statement" & @CRLF & _
"Africa dentist hope paper stay" & @CRLF & _
"after deposit horse paragraph step" & @CRLF & _
"again describe hospital parents stick" & @CRLF & _
"against desert hot park still" & @CRLF & _
"age design hotel part stone" & @CRLF & _
"ago desk hours party stood" & @CRLF & _
"agree destination house passed stop" & @CRLF & _
"aide developed how passengers store" & @CRLF & _
"air diary however password storm" & @CRLF & _
"alarm dictionary huge past story" & @CRLF & _
"all did human pattern stove" & @CRLF & _
"almost didn't hundred pay straight" & @CRLF & _
"alone died husband payment strange" & @CRLF & _
"already difference I pedestrians street" & @CRLF & _
"also different I'll pen strong" & @CRLF & _
"although digital ice pencil students" & @CRLF & _
"always diner idea people study" & @CRLF & _
"am dinner if per subject" & @CRLF & _
"ambulance direct important period subtract" & @CRLF & _
"America direction in perishable subway" & @CRLF & _
"amount directions inches person such"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")