use strict;
my $str = '
a dance high our spouse
able danger hill out spring
about dark him outside square
above daughter himself over stairs
accident day hint own stairway
acid decide his oxygen stand
across decided history page stars
act decimal hold paint start
add deep hole pair state
admission delivery home pants statement
Africa dentist hope paper stay
after deposit horse paragraph step
again describe hospital parents stick
against desert hot park still
age design hotel part stone
ago desk hours party stood
agree destination house passed stop
aide developed how passengers store
air diary however password storm
alarm dictionary huge past story
all did human pattern stove
almost didn\'t hundred pay straight
alone died husband payment strange
already difference I pedestrians street
also different I\'ll pen strong
although digital ice pencil students
always diner idea people study
am dinner if per subject
ambulance direct important period subtract
America direction in perishable subway
amount directions inches person such';
my $regex = qr/^[a]\w+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}