const regex = /(?<=\()\d{1,}\.{0,}\/{0,}-{0,}\d{0,}(?=\))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\()\\d{1,}\\.{0,}\\\/{0,}-{0,}\\d{0,}(?=\\))', 'g')
const str = `Account Name (123.54)
Account Name (123)
Account Name (123/54)
Account Name (123-54)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}