#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=\()\d{1,}\.{0,}\/{0,}-{0,}\d{0,}(?=\))"
Local $sString = "Account Name (123.54)" & @CRLF & _
"Account Name (123)" & @CRLF & _
"Account Name (123/54)" & @CRLF & _
"Account Name (123-54)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")