using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\()\d{1,}\.{0,}\/{0,}-{0,}\d{0,}(?=\))";
string input = @"Account Name (123.54)
Account Name (123)
Account Name (123/54)
Account Name (123-54)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}