$re = '/^"([^"\\\\]*(?:\\\\.[^"\\\\]*)*)"$/';
$str = '"quoted text"';
$subst = "$0,";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;