#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^"([^"\\]*(?:\\.[^"\\]*)*)"$"
Local $sString = ""quoted text""
Local $sSubst = "$0,"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)