use strict;
my $str = '"quoted text"';
my $regex = qr/^"([^"\\]*(?:\\.[^"\\]*)*)"$/p;
my $subst = '$0,';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";