re = /http[^\]]*/m
str = 'Lorem ipsum [http://domain.tld/] dolor.
Lorem ipsum [https://domain.tld/] dolor.
Lorem ipsum [https://domain.tld/index.html] dolor.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end