package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)http[^\]]*`)
var str = `Lorem ipsum [http://domain.tld/] dolor.
Lorem ipsum [https://domain.tld/] dolor.
Lorem ipsum [https://domain.tld/index.html] dolor.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}