$re = '/http[^\]]*/m';
$str = 'Lorem ipsum [http://domain.tld/] dolor.
Lorem ipsum [https://domain.tld/] dolor.
Lorem ipsum [https://domain.tld/index.html] dolor.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);