re = /\[\[([^|\]#]+)(?:#[^\]]*)?(?:\|([^\]]+))?\]\]/m
str = '[[page]]
[[page|displayed text]]
[[page#section]]
[[page#section|displayed text]]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end