$re = '/\[\[([^|\]#]+)(?:#[^\]]*)?(?:\|([^\]]+))?\]\]/m';
$str = '[[page]]
[[page|displayed text]]
[[page#section]]
[[page#section|displayed text]]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);