package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[\[([^|\]#]+)(?:#[^\]]*)?(?:\|([^\]]+))?\]\]`)
var str = `[[page]]
[[page|displayed text]]
[[page#section]]
[[page#section|displayed text]]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}