re = /(?<=^|[^\S\r\n]+|\})\.\D[\w-]+/m
str = '.class {}
@media print {
.class {}
}
#id {
.class {}
}
.class {}.class {} .class {}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end