import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^|[^\\S\\r\\n]+|\\})\\.\\D[\\w-]+";
final String string = ".class {}\n"
+ "@media print {\n"
+ " .class {}\n"
+ "}\n\n"
+ "#id {\n"
+ " .class {}\n"
+ "}\n\n"
+ ".class {}.class {} .class {}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}