$re = '/(?<=^|[^\S\r\n]+|\})\.\D[\w-]+/m';
$str = '.class {}
@media print {
.class {}
}
#id {
.class {}
}
.class {}.class {} .class {}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);