# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!.*\-{2}.*)(?!.*\+{2}.*)(?!.*\.{2}.*)(?P<major>(?!0)(\d*)|([0[^\d]))((?>\.)(?P<minor>\g<1>))\.(?P<patch>\g<minor>)(?![\+\-][^a-zA-Z0-9])(\g<2>(\-(?P<release>[a-zA-Z0-9\.-]+)))?(\+(?P<build>\g<9>))?$"
test_str = ("#good\n"
"0.1.2\n"
"1.2.3\n"
"10.20.3\n"
"1.2.3-alpha.23-pre\n"
"12.12.3-123.hexagon+dontmakemecompileplea.se\n"
"1.2.3-alpha-dev.51-something+mybuild-1-4-1975-clang\n"
"4.3.22+mybuild\n"
"4.1.405+hexa.13331-objectfiles\n\n"
"# bad\n"
"01.2.3\n"
"1.02.3\n"
"2.3.04\n"
"a.1.1\n"
"1.a.1\n"
"1.1.a\n"
"1.2.3-rele..ase+build\n"
"1.2.3-release-something+..build\n"
"1.2.3-rele--ase+build\n"
"1.2.3-release-something+--build\n"
"1.2.3-release++build\n"
"1.2.3+-release-something-build")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.