#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*\-{2}.*)(?!.*\+{2}.*)(?!.*\.{2}.*)(?P<major>(?!0)(\d*)|([0[^\d]))((?>\.)(?P<minor>\g<1>))\.(?P<patch>\g<minor>)(?![\+\-][^a-zA-Z0-9])(\g<2>(\-(?P<release>[a-zA-Z0-9\.-]+)))?(\+(?P<build>\g<9>))?$"
Local $sString = "#good" & @CRLF & _
"0.1.2" & @CRLF & _
"1.2.3" & @CRLF & _
"10.20.3" & @CRLF & _
"1.2.3-alpha.23-pre" & @CRLF & _
"12.12.3-123.hexagon+dontmakemecompileplea.se" & @CRLF & _
"1.2.3-alpha-dev.51-something+mybuild-1-4-1975-clang" & @CRLF & _
"4.3.22+mybuild" & @CRLF & _
"4.1.405+hexa.13331-objectfiles" & @CRLF & _
"" & @CRLF & _
"# bad" & @CRLF & _
"01.2.3" & @CRLF & _
"1.02.3" & @CRLF & _
"2.3.04" & @CRLF & _
"a.1.1" & @CRLF & _
"1.a.1" & @CRLF & _
"1.1.a" & @CRLF & _
"1.2.3-rele..ase+build" & @CRLF & _
"1.2.3-release-something+..build" & @CRLF & _
"1.2.3-rele--ase+build" & @CRLF & _
"1.2.3-release-something+--build" & @CRLF & _
"1.2.3-release++build" & @CRLF & _
"1.2.3+-release-something-build"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")