import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\-{2}.*)(?!.*\\+{2}.*)(?!.*\\.{2}.*)(?P<major>(?!0)(\\d*)|([0[^\\d]))((?>\\.)(?P<minor>\\g<1>))\\.(?P<patch>\\g<minor>)(?![\\+\\-][^a-zA-Z0-9])(\\g<2>(\\-(?P<release>[a-zA-Z0-9\\.-]+)))?(\\+(?P<build>\\g<9>))?$";
final String string = "#good\n"
+ "0.1.2\n"
+ "1.2.3\n"
+ "10.20.3\n"
+ "1.2.3-alpha.23-pre\n"
+ "12.12.3-123.hexagon+dontmakemecompileplea.se\n"
+ "1.2.3-alpha-dev.51-something+mybuild-1-4-1975-clang\n"
+ "4.3.22+mybuild\n"
+ "4.1.405+hexa.13331-objectfiles\n\n"
+ "# bad\n"
+ "01.2.3\n"
+ "1.02.3\n"
+ "2.3.04\n"
+ "a.1.1\n"
+ "1.a.1\n"
+ "1.1.a\n"
+ "1.2.3-rele..ase+build\n"
+ "1.2.3-release-something+..build\n"
+ "1.2.3-rele--ase+build\n"
+ "1.2.3-release-something+--build\n"
+ "1.2.3-release++build\n"
+ "1.2.3+-release-something-build";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}