use strict;
my $str = 'a:4:{s:5:"dates";a:2:{s:7:"created";s:27:"2017-11-03T01:14:56.582259Z";s:8:"imported";s:27:"2017-11-03T01:14:56.582259Z";}s:11:"displayName";s:12:"Donald Trump";s:11:"description";s:17:"Donald John Trump";s:6:"themes";s:10:"apple, Businessman, Politician";}';
my $regex = qr/s:\d+:"themes";s:\d+:"[\w,\s]*(\bbusinessman\b)[\w,\s]*";/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}