package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)s:\d+:"themes";s:\d+:"[\w,\s]*(\bbusinessman\b)[\w,\s]*";`)
var str = `a:4:{s:5:"dates";a:2:{s:7:"created";s:27:"2017-11-03T01:14:56.582259Z";s:8:"imported";s:27:"2017-11-03T01:14:56.582259Z";}s:11:"displayName";s:12:"Donald Trump";s:11:"description";s:17:"Donald John Trump";s:6:"themes";s:10:"apple, Businessman, Politician";}`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}