# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(personal-trainers|fysiotherapeuten)(\/pagina\/([0-9]+))?\/?(\?([a-zA-Z0-9.-=&]+))?\/?"
test_str = ("personal-trainers/?latitude=52.1816907&longitude=5.9587436&specialisme=1&trainings=0\n"
"http://localhost:8080/personal-trainers/?latitude=52.1816907&longitude=5.9587436&specialisme=1&trainings=0\n"
"http://localhost:8080/personal-trainers/pagina/2/?latitude=52.1816907&longitude=5.9587436&specialisme=1&trainings=0")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.