const regex = /(personal-trainers|fysiotherapeuten)(\/pagina\/([0-9]+))?\/?(\?([a-zA-Z0-9.-=&]+))?\/?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(personal-trainers|fysiotherapeuten)(\\\/pagina\\\/([0-9]+))?\\\/?(\\?([a-zA-Z0-9.-=&]+))?\\\/?', 'gm')
const str = `personal-trainers/?latitude=52.1816907&longitude=5.9587436&specialisme=1&trainings=0
http://localhost:8080/personal-trainers/?latitude=52.1816907&longitude=5.9587436&specialisme=1&trainings=0
http://localhost:8080/personal-trainers/pagina/2/?latitude=52.1816907&longitude=5.9587436&specialisme=1&trainings=0`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);