package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^2(([0-5]\d{2})|([6-8](([1][9])|([2-9]\d)))|([9](([2][1-9])|[3-9]\d)))$`)
var str = `2600
2599
1999
2000
2618
2619
2899
2900
2921
2920
2999
3000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}