$re = '/^2(([0-5]\d{2})|([6-8](([1][9])|([2-9]\d)))|([9](([2][1-9])|[3-9]\d)))$/m';
$str = '2600
2599
1999
2000
2618
2619
2899
2900
2921
2920
2999
3000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);