import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^2(([0-5]\\d{2})|([6-8](([1][9])|([2-9]\\d)))|([9](([2][1-9])|[3-9]\\d)))$";
final String string = "2600\n"
+ "2599\n"
+ "1999\n"
+ "2000\n"
+ "2618\n"
+ "2619\n"
+ "2899\n"
+ "2900\n"
+ "2921\n"
+ "2920\n"
+ "2999\n"
+ "3000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}