// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([\]\)]),(\s*\n*\s*)([\]\)])").unwrap();
let string = "[[
'id' => 'palette-3',
'color1' => [ 'color' => '#3eaf7c' ],
'color2' => [ 'color' => 'rgb(207, 216, 225)' ],
'color3' => [ 'color' => '#f0f0f0' ],
'color4' => [ 'color' => '#c8c8c8' ],
'color5' => [ 'color' => '#f0f0f0' ],
],
]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}